CMake 3.0.0 or higher is required. You are running version 2.8.12.2

发布于 2020-03-19 09:57:25

1.cmake --version 查看 cmake版本

如果提示下面错误 安装新版本 cmake
CMake 3.0.0 or higher is required. You are running version 2.8.12.2

下载Cmake

wget https://cmake.org/files/v3.6/cmake-3.6.2.tar.gz

解压Cmake

tar xvf cmake-3.6.2.tar.gz && cd cmake-3.6.2/

编译安装cmake

./bootstrap
gmake
gmake install

查看编译后的cmake版本

/usr/local/bin/cmake --version

移除原来的cmake版本

yum remove cmake -y

新建软连接

ln -s /usr/local/bin/cmake /usr/bin/

终端查看版本

cmake --version

出现版本表示成功!cmake编译完成

wget https://cmake.org/files/v3.6/cmake-3.6.2.tar.gz

tar xvf cmake-3.6.2.tar.gz && cd cmake-3.6.2/
./bootstrap
gmake
gmake install
/usr/local/bin/cmake --version
0 条评论

发布
问题